Another Potential Heartbleed Plugged

Another Potential Heartbleed Plugged

Hot on the heels of Heartbleed another OpenSSL has been discovered and corrected. Discovered in May, this latest exploit could allow attacks between servers and client using OpenSSL but rest assured it is a difficult exploit to execute. Relying on a “man-in-the-middle” attack, a compromised router, switch, and etc. , to strip encryption from transmitted data.

So with all that scary stuff out of the way here’s the skinny: The average Joe has nothing to worry about as this exploit doesn’t effect desktop browsers like Firefox, IE, Safari, or Chrome. This is mostly a server related risk (so keep an eye out Admins!) but as stated above it has already been patched with the latest update.

Safe Browsing everyone and have a great weekend.

For more information check here